Reply
Thread Tools

Fistofunk

CoolGame is alright

This game is alright but there are too many technical problems at least from my end, it may be some of my computer but I have updated graphics card drivers, and everything. For one it crashed when I first tried to run the game apparently because I can't run dx11 in the game, I get into the game and I notice an obvious difference, but it did tone down all my graphics settings when it crashed, it said..Anyway. I'd like to like it, but I dunno if I wanna spend the money and get crashes all the time, cause it crashed again while I was playing for no apparent reason(though of course there was a reason). Ehhhhh..I think I'm better off sticking to ARPGS. Great game though, Funcom!

Darkstride

Darkstride's Avatar

If you haven't already, check the Technical Solutions part of the forum. TSW does have some issues when it comes to Windows 8 and SLI and DX11 with some setups. Personally I have played since beta and have never had any major issues at all besides a fluke period of latency spikes. I don't know if that was actually TSW's fault though. I'm not claiming the game is perfect, but I would say don't give up just cause you had a crash and haven't found optimal settings yet. I don't know what your setup is, but the GeForce Experience will suggest some optimal settings for you based on your system.

Xyranth

Xyranth's Avatar

Don't worry about this one. We've already lost them to ARPG's...

But really though, the game is playable and very fun once you get around the little quirks here and there. Devs are always trying to find new ways to improve the game though, so give them feedback with your build, chip set, etc, and they can more than likely help you.

Also, Kingsmouth has some REALLY laggy areas in it, though. If I'm in Kingsmouth, especially around the first mission hub at the Police Station, I get so much lag it's unbearable. In a dungeon, the game runs like warm butter. So it's a toss up at times, but you learn to get around it if you really enjoye the game. I know I did, and still do, regardless of incremental lag.

After updating my drivers during the 1.6 fiasco, I haven't had the game crash on me at all. Not even once. Well, when my Internet would die, but that's a completely different issue not tied to the game...Ha.

Wolfpack

Wolfpack's Avatar

Playing using DX9 tends to fix crashing issues. Also the 32-bit client of Windows has problems -- 64-bit windows will also help.
Last edited by Wolfpack; 04-05-2013 at 12:15 AM.

willySW01

willySW01's Avatar

Quote:
Originally Posted by Wolfpack View Post
Playing using DX9 tends to fix crashing issues. Also the 32-bit client of Windows has problems -- 64-bit windows will also help.
^ This

On my main computer (32 bit Windows Vista -- I know, but I won't invest $100 for 7 to upgrade an old system), I used to average one crash per day (which some would say "I'd kill to have ONLY one crash per day!").

When 1.5.? came out, massive lag was introduced to Kingsmouth around the Sheriff's office and also around Edgar's Scrapyard. I used to be able to get semi-decent frame rates in those areas BEFORE the 1.5.? patches, but now it's slide show city and some freeze-ups which take 10-15 seconds to catch up to the system.

When 1.6 came along, crashes increased dramatically. And a lot of the crashes were related to the DLC missions (some of which may have been fixed in the interim), on early launch day, parts 1-4 of the storyline mission crashed when entering or leaving one of the instances, some multiple times.


I got fed up with the crashes and the lag in KS so I swapped to my second computer to play TSW -- this is a 64 bit with a lesser video card, so I dialed back a bit on graphics (the computer still runs Windows Vista, see also I won't pay $100+ to update to 7) but the crashes have stopped entirely. I haven't messed around in KS to see if it's laggy but I only went to KS to farm signets at the airport, anyway.

But, getting rid of the daily crashes was huge, because I was really getting fed up, mainly due to how long it took an older machine with Vista to load TSW and get to where I could play the game. 64 bit still takes a while to load, but I only have to do it once now with no more crashes.
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 05:41 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.