Results 1 to 7 of 7

Thread: Quest Bug: Ami Legend 2/5

  1. #1

    Quest Bug: Ami Legend 2/5

    I started this quest off, holding back the first attacking ak'ab wave then another player came along and it looked like they took over the quest as after the boss came out at the end of the waves he left. I then had to leave the mission area and jump back in to restart the waves again and to get the mission to the next tier.

  2. #2
    Just had it happen to me too. Same fix worked thankfully.

  3. #3
    I've been trying to complete this mission for several hours now. I am on tier 2 and the ak'ab won't spawn and attack me. I have been roaming the area for a long time and I get nothing. Looks like this bug isn't fixed. In the hours I have been here I have seen several other players come through and when they do the monsters spawn. The objective doesn't complete for me. Getting very frustrated !!!

  4. #4
    I'm stuck at this too. Exiting and reentering mission area doesn't seem to fix this

    I've opened a petition...

  5. #5
    I tried this again this morning, both before and after the restart and didn't get anything. I even watched as 2 different people came through and got the spawn. I assisted trying to complete objective but it didn't work. Still says "stop the attacking ak'ab." I sent a petition last night and still haven't heard anything.

  6. #6
    Ok, I found a workaround:

    - take another main mission from another NPC. This will put Ami Legend on pause.
    - take Ami Legend again. It will resume from the beginning of tier 2, when you need to follow the forest trail. Go to the mission markers and if you are lucky the little ak'abs will spawn as they should and won't bug again.

    Hope it helps!

  7. #7
    Thank you! I tried pausing as suggested by selecting another mission and when I went back it worked out perfectly, starting me at the beginning of tier 2 and the monsters spawned. Thanks again!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts