Page 1 of 6 123 ... LastLast
Results 1 to 10 of 55

Thread: How to fix add-ons in the 1.0.2 patch.

  1. #1

    How to fix add-ons in the 1.0.2 patch.

    Thought I'd make a separate thread on this so people will notice it.

    1.0.2 apparently broke loading the add-ons properly when placed in the \Data\Gui\Customized\Flash\ directory.

    When doing these changes you might have to restart your client.

    What you need to do is to copy the .swf files from \Data\Gui\Customized\Flash\ to \Data\Gui\Default\Flash\, but before doing so make sure to rename any of the original files in \Data\Gui\Default\Flash\ that might get overwritten (like MainMenuWindow.swf, FullscreenVideoPlayer.swf etc.).
    This is so you can restore them once it's fixed (likely with the 1.1 patch).
    When it's fixed you should also remove files that were copied over, which means all custom files that didn't already exist in \Data\Gui\Default\Flash\ previously.

    You do not need to change/move/copy any XML files.

    Some have said the above doesn't work for them, in that case add the following line to MainPrefs.xml, LoginPrefs.xml, CharPrefs.xml and Modules.xml located in \Data\Gui\Customized\
    <!-- $Change: 310823 $ (must be within the first 200 characters of the file) -->


    For TextColors.xml add the following line to the file in \Data\Gui\Customized\ - overwrite any similar line if it already exists.
    <!-- $Change: 310823 $ (must be within the first 200 characters of the file) -->


    Right now the patcher doesn't seem to overwrite the changed files, which is good (but possibly an oversight as well) in the current situation.

    Enjoy your add-ons once again.


    Update on the issue from Testlive: http://forums-beta.thesecretworld.co...3&postcount=15
    Quote Originally Posted by Haven
    Yes, this is the workaround we just found internally as well We've identified the issues involved and they are now fixed internally. The fix should hopefully be going out to Live next week with update 1.0.3.
    Last edited by -Viper; 07-17-2012 at 04:59 PM.
    Viper of SUN
    - Playing as Viper on Grim.

    Follow my add-on development: http://tswaddons.wordpress.com/

  2. #2
  3. #3
    Thanks again -Viper, just to clarify for others, you have to rename the ORIGINAL file for this to work, not the addon file. Personally I just added overwritten to the end to remind me which files I've replaced.

    ~Apokalupsis
    Grim

  4. #4
    Updated main post with more information.
    Viper of SUN
    - Playing as Viper on Grim.

    Follow my add-on development: http://tswaddons.wordpress.com/

  5. #5
    Quote Originally Posted by LordSmada View Post
    Thanks again -Viper, just to clarify for others, you have to rename the ORIGINAL file for this to work, not the addon file.
    Right, I added that as well - thanks.
    Viper of SUN
    - Playing as Viper on Grim.

    Follow my add-on development: http://tswaddons.wordpress.com/

  6. #6
  7. #7
    Maybe this'll work, but I'm not playing the game until they enable the customized folder again.

    Disabling the option to use mods on purpose without even notifying the players about this rather steep change in the patchnotes is not worth my time or money.
    Last edited by Xyleya; 07-17-2012 at 04:44 PM.

  8. #8
    Quote Originally Posted by Xyleya View Post
    Maybe this'll work, but I'm not playing the game until they enable the customized folder again.

    Disabling the option to use mods on purpose without even notifying the players about this rather steep change in the patchnotes is not worth my time or money.
    Wasn't on purpose, it was a bug.

  9. #9
    Quote Originally Posted by -Viper View Post
    Thought I'd make a separate thread on this so people will notice it.

    1.0.2 apparently broke loading the add-ons properly when placed in the \Data\Gui\Customized\Flash\ directory.

    When doing these changes you might have to restart your client.

    What you need to do is to copy the .swf files from \Data\Gui\Customized\Flash\ to \Data\Gui\Default\Flash\, but before doing so make sure to rename any of the original files in \Data\Gui\Default\Flash\ that might get overwritten (like MainMenuWindow.swf, FullscreenVideoPlayer.swf etc.).
    This is so you can restore them once it's fixed (likely with the 1.1 patch).
    When it's fixed you should also remove files that were copied over, which means all custom files that didn't already exist in \Data\Gui\Default\Flash\ previously.

    You do not need to change/move/copy any XML files.

    Some have said the above doesn't work for them, in that case add the following line to MainPrefs.xml, LoginPrefs.xml, CharPrefs.xml and Modules.xml located in \Data\Gui\Customized\
    <!-- $Change: 310823 $ (must be within the first 200 characters of the file) -->


    For TextColors.xml add the following line to the file in \Data\Gui\Customized\ - overwrite any similar line if it already exists.
    <!-- $Change: 310823 $ (must be within the first 200 characters of the file) -->


    Right now the patcher doesn't seem to overwrite the changed files, which is good (but possibly an oversight as well) in the current situation.

    Enjoy your add-ons once again.


    Update on the issue from Testlive: http://forums-beta.thesecretworld.co...3&postcount=15
    Thanks for taking the time to update us on how to resolve these issues!

  10. #10
    Quote Originally Posted by Samoan View Post
    Wasn't on purpose, it was a bug.
    Yeah, keep believing that.

    If it would've been a bug, then how come FC doesn't fix it or even acknoledge it?

    On testlive people have told them that AddOns don't work in 1.0.2 and they've done nothing, but kept it the way it is now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •